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Ako programovať vo Visual Basic for Applications 
V niektorých prípadoch potrebujeme používať funkcionalitu mimo rozsah tej, ktorú ponúka Microsoft 

Excel. Určitým spôsobom „zachraňuje situáciu“ nahraté makro, ktoré je však primárne určené na 

zautomatizovanie činností v Exceli.  Špecifickú funkcionalitu si môžeme naprogramovať a to 

prostredníctvom Microsoft Visual Basic for Applications. Microsoft Visual Basic for Applications je 

„odľahčená“ verzia programovacieho jazyka Microsoft Visual Basic. 

Pre sprístupnenie prostredia Microsoft Visual Basic for Applications si musíme najprv zobraziť kartu 

Developer a to cez File > Options. V otvorenom okne Excel Options vľavo zvolíme možnosť 

Customize Ribbon a úplne vpravo začiarkneme Developer.  

 

 
 

Karta Developer sa zvyčajne umiestni ako posledná karta medzi ostatnými.  
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Ukladanie súboru 
Narozdiel od starších verzií Microsoft Excel musíme súbor s makrom (či už nahratým alebo 

naprogramovaným) uložiť pod špeciálnym formátom a to: Excel Macro-Enabled Workbook. 

 

Ikonka súboru vyzerá nasledovne (súbor má príponu .xlsm): 

 

Povolenie makier 
Kvôli bezpečnosti je implicitne povolenie makier zakázané (v minulosti sa prostredníctvom makier 

spúšťali vírusy). Používateľ musí po otvorení súboru makro daného súboru povoliť.  
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To ako bude Excel pristupovať k súborom obsahujúce makro závisí od globálneho nastavenia Macro 

Security v karte Developer. 

  

Máme na výber nasledovné možnosti: 

Disable all macros without notification – zakáže všetky makrá, notifikácia sa nezobrazí 

Disable all macros with notification – zakáže všetky makrá, notifikácia sa zobrazí 

Disable all macros except digitally signed macros – zakáže všetky makrá okrem digitálne 

podpísaných 

Enable all macros (not recommended; potentionally dangerous code can run) – povolí všetky makrá 

(neodporúča sa; potencionálne sa môže spustiť nebezpečný kód) 
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Prostredie Microsoft Visual Basic 
Karta Developer > Visual Basic 

Po zvolení tlačidla Visual Basic dostaneme nasledovné okno: 

 

 
 

1. Naľavo vidíme tzv. Project Explorer, ktorý obsahujú objekty otvoreného zošita (alebo zošitov).  

2. Napravo nájdeme okno editora, kde budeme písať (alebo po nahraní makra vidieť) samotný kód 

VBA. 

3. Okno, ktoré zobrazuje vlastnosti  aktívneho objektu. Využijeme hlavne pri tvorbe formulárov  

Programovanie vo VBA 
V princípe môžeme programovať dva typy programov 

Sub = Subroutine = podprogram.  Obsahuje príkazy Microsoft VBA, ktoré v Exceli vykonajú konkrétnu 

činnosť (napr. vymazanie oblasti buniek, zlúčenie, tvorba grafu, kontingenčnej tabuľky, ...).  

Subroutine nevracia do bunky žiadnu hodnotu. 

Function = funkcia. .  Obsahuje príkazy Microsoft VBA, ktoré využijeme napr. k vytvoreniu vlastnej 

funkcie (napr. obvod obdĺžnika, vnútorný obvod rúry a podobne). Function vracia návratovú 

hodnotu. 

V obidvoch prípadoch začneme vložením modulu a to zvolením Insert a Module, tak ako to vyjadruje 

nasledovný obrázok: 

1 

2 

3 
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V Project Explorer sa zobrazí skupina Modules, ktorá obsahuje modul s názvom Module1. 

 
 

V ďalšom kroku prejdeme do Insert > Procedure... 
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Máme na výber z niekoľkých možností.  Podľa situácie vyberieme Sub ak chceme vytvoriť 

podprogram (niekde označovaná aj procedúra) alebo Function, ak chceme vytvoriť funkciu. Property 

využijeme na získanie alebo priraďovanie vlastností objektov. 

 

 
  

Po potvrdení môžeme do okna kódu písať zdrojový kód vo Visual Basic for Applications. 

Formátovanie tabuľky môže vyzerať nasledovne: 

 
Sub Macro1() 

' 

' Macro1 Macro 

' 

    ActiveCell.Range("A1:A3").Select 

    Selection.Borders(xlDiagonalDown).LineStyle = xlNone 

    Selection.Borders(xlDiagonalUp).LineStyle = xlNone 

    With Selection.Borders(xlEdgeLeft) 

        .LineStyle = xlContinuous 

        .ColorIndex = 0 

        .TintAndShade = 0 

        .Weight = xlThin 

    End With 
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    With Selection.Borders(xlInsideHorizontal) 

        .LineStyle = xlContinuous 

        .ColorIndex = 0 

        .TintAndShade = 0 

        .Weight = xlThin 

    End With 

    Selection.Borders(xlDiagonalDown).LineStyle = xlNone 

    Selection.Borders(xlDiagonalUp).LineStyle = xlNone 

   With Selection.Borders(xlEdgeRight) 

        .LineStyle = xlContinuous 

        .ColorIndex = 0 

        .TintAndShade = 0 

        .Weight = xlMedium 

    End With 

    Selection.Borders(xlInsideVertical).LineStyle = xlNone 

    With Selection.Borders(xlInsideHorizontal) 

        .LineStyle = xlContinuous 

        .ColorIndex = 0 

        .TintAndShade = 0 

        .Weight = xlThin 

    End With 

End Sub 

Jedná sa o tzv. subroutine. 

Kopírovanie hárka vyzerá nasledovne: 

Sub kopirujHarok() 

' 

' kopirujHarok Macro 

' 

    Sheets("Sheet1").Select 

    Sheets("Sheet1").Copy After:=Sheets(3) 

End Sub 

Formátovanie kódu 
Pri kóde, ktorý zapisujeme do editora by sme sa mali držať nasledovných odporúčaní: 

 odsadenie  

 príkazy píšeme do jednotlivých riadkov 

Nevhodná ukážka formátovania kódu: 

 

Vhodná ukážka formátovania kódu: 
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Môžeme použiť  panel Edit (menu View > Toolbar > Edit), kde nájdeme Intend (odsadenie doľava) 

alebo Outdend (odsadenie doprava)  

 

Nahrávanie makra vs programovanie – efektívnosť kódu 
Makro, ktoré nahráme má vo väčšine prípadoch zbytočne dlhý kód.  Porovnajme nasledovné riešenia: 

Kód na vyfarbenie jednej bunky (prostredníctvom nahrávania makra): 

 

Sub vyfarbi() 

' 

' vyfarbi Macro 

' 

' 

    With Selection.Interior 

        .Pattern = xlSolid 

        .PatternColorIndex = xlAutomatic 

        .Color = 65535 

        .TintAndShade = 0 

        .PatternTintAndShade = 0 

    End With 

End Sub 

Ako by sme to mohli naprogramovať my: 

Sub vyfarbi() 

' 

' vyfarbi Macro 

' 

' 

ActiveCell.Interior.Color = 65535 

End Sub 

Tvorba vlastnej funkcie (function) 
Aj keď Microsoft Excel obsahuje veľké množstvo funkcií (SUM, AVERAGE, MIN, MAX, COUNT, IF, ...), 

niekedy je potrebné v praxi použiť svoju vlastnú (napr. obvod obdĺžnika, vnútorný objem rúry). Na 
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vytvorenie vlastnej funkcie využijeme makro, ktoré si naprogramujeme v Microsoft Excel VBA. VBA = 

Visual Basic for Applications. 

Ukážku si predvedieme na vytvorenie vlastnej funkcie sčítania dvoch buniek. 

V karte Developer zvolíme tlačidlo Visual Basic. 

Do neho zapíšeme nasledovný zdrojový kód:  

 

Function obvodObdlznika(stranaA, stranaB) 

    obvodObdlznika = 2 * (stranaA + stranaB) 

End Function 

 

Zdrojový kód obsahuje anglické slová (príkazy, ktorým rozumie Microsoft Excel VBA) a slovenské 

slová, ktoré sme zadali my. 

 

Function obvodObdlznika(stranaA, stranaB) – je náš vlastný názov funkcie (bez 

medzier a diakritiky), ktorú potom použijeme v hárku. Obsahuje dva argumenty (premenné): 

stranaA pre označenie prvej bunky, s ktorou počítame a stranaB pre označenie druhej bunky. 

 

obvodObdlznika = 2 * (stranaA + stranaB)– Excel VBA vypočíta obvod na základe  

vzorca, ktorý sme zadali a výsledok „odovzdá“ do premennej s názvom obvodObdlznika. Názov 

premennej obvodObdlznika musí byť identický s názvom, ktorý sme použili pri príkaze 

Function obvodObdlznika(stranaA, stranaB) 

 

End Function – týmto príkazom končí funkcia 

 

V Exceli vložíme nami definovanú funkciu podobne ako jednu z ďalších existujúcich, viď obrázok 

nižšie: 

 
 

 

 



13 
 

Doplnenie pomocníka k používateľským funkciám 
Karta Developer > Macros  

V karte Developer vyberieme tlačidlo Macros. Ak sa nami vytvorená funkcia v zozname nenachádza, 

je potrebné ju vypísať (musíme mať však otvorený súbor, kde sa dané makro nachádza). Ak sa názov 

funkcie v zozname nachádza, tlačidlá napravo sa zaktívnia. Vyberieme Options... 

 

 

Čo je premenná 
Premenná je dočasné miesto v pamäti, ktorú využijeme na ukladanie ľubovoľnej hodnoty. Každá 

premenná má názov pozostávajúci z alfanumerických znakov.  
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Názov premennej by mal logicky nadväzovať na to, čo obsahuje (napr. dph, obrat, vysledok, bunka1, 

chybovaSprava a podobne). Zápis je potom nasledovný: 

dph = 1.19 

obratDph = obrat * dph  

chybovaSprava = “Pozor! Zadali ste hodnotu mimo rozsah!” 

Premennú deklarujeme príkazom Dim, napr. 

Dim obratDph As Double 

Double je vlastne dátový typ, ktorý reprezentuje desatinné číslo.  Premenná by nemala nadobúdať 

iný typ údajov, inak dôjde k chybe.  

Deklarácia typu premennej nie je záväzná, no kvôli čitateľnosti a prehľadnosti kódu odporúčam 

použiť nastavenie Require Variable Declaration v okne Options, menu Tools.  

 

 



15 
 

Dátové typy 
 

Dátový typ Počet bytov Rozsah hodnôt 

Boolean 2 True alebo False 
Integer 2 -32,768 do 32767 
Long 4 -2,147,483,648 do 2,147,483,647 
Single 4 -3.402823E38 do 1.401298E45 
Double 
(negative) 

8 -1.79769313486232E308 do -
4.94065645841247E-324 

Double 
(positive) 

8 4.94065645841247E-324 do 
1.79769313486232E308 

Currency 8 -922,337,203,685,477.5808 do 
922,337,203,685,477.5807 

Date 8 1/1/100 to 12/31/9999 
String 1(ak 1 znak) Veľkosť závisí od počtu znakov 
Object 4 Akýkoľvek definovaný objekt 
Variant Variabilný Akýkoľvek dátový typ 
Used defined Variabilný Variabilný 
 

Zrovnanie dátového typu VBA s formátom bunky v MS Excel 
 

Visual Basic for Application Excel 

Byte (nemá) 

Boolean (nemá) 

Integer Číslo 

Long Číslo 

Date Dátum 

Object (nemá) 

String Text 

Variant  Všeobecný 
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Vypisovanie hodnôt (MsgBox, Debug.print) 
Použijeme v prípade, ak chceme používateľovi vypísať v okne správu. Podľa typu odpovede (tlačidla) 

môžeme ďalej spracovať odpoveď. 

 

Príkaz, ktorý sme použili: 

MsgBox "Potvrdením vytvoríme graf!" 

Syntax príkazu 

MsgBox(prompt, buttons , title, helpfile, context) 

prompt – povinný parameter. Je vlastne reťazec, ktorý sa v okne zobrazí 

buttons – nepovinný parameter. Obsahuje číslo typu tlačidla podľa ktorého sa tlačidlo bude 

zobrazovať. 

Vybrané typy tlačidiel 

Constant Value Description 

vbOKOnly 0 Display OK button only. 

vbOKCancel 1 Display OK and Cancel buttons. 

vbAbortRetryIgnore 2 Display Abort, Retry, and Ignore buttons. 

vbYesNoCancel 3 Display Yes, No, and Cancel buttons. 

vbYesNo 4 Display Yes and No buttons. 

vbRetryCancel 5 Display Retry and Cancel buttons. 

vbCritical 16 Display Critical Message icon. 

vbQuestion 32 Display Warning Query icon. 

vbExclamation 48 Display Warning Message icon. 

vbInformation 64 Display Information Message icon. 

 

title – nepovinný parameter, zobrazí okno nami definovaným nadpisom 

helpfile – nepovinný parameter, obsahuje odkaz na súbor pomocníka 

context –nepovinný parameter hesla zo súboru pomocníka 

Návratová hodnota 
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Constant Value Description 

vbOK 1 OK 

vbCancel 2 Cancel 

vbAbort 3 Abort 

vbRetry 4 Retry 

vbIgnore 5 Ignore 

vbYes 6 Yes 

vbNo 7 No 

 

Príklad 

 

 

Na vypisovanie hodnôt môže použiť príkaz: 

Debug.Print  

Príklad: 

Debug.Print "Aktuálna hodnota DPH je " & dph 

Narozdiel do MsgBox, výstupnú hodnotu zobrazí v Immediate Window  
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Poznámka: Immediate Window môžeme zobraziť/skryť cez  View > Immediate Window) 

 

Vstup hodnoty prostredníctvom okna 
Pri MsgBox sme smerom k používateľovi vypísali nejakú správu, no v niektorých prípadoch 

potrebujeme, aby používateľ zadal hodnotu, ktorú chceme dodatočne spracovať 

 

Príkaz, ktorý sme použili: 

InputBox "Zadajte svoje meno a priezvisko" 
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Syntax príkazu 

InputBox(prompt, title, default, left, top, helpfile, helpcontextid, type) 

najdôležitejšie parametre 

prompt – povinný parameter. Je vlastne reťazec, ktorý sa v okne zobrazí 

title – nepovinný parameter. Titulok okna 

default – východzia hodnota, ktorú vopred Excel vypíše 

Odpoveď môžeme spracovať napr. takýmto spôsobom 

 

Ukážka použitia a spracovania InputBox 

 

 

Najpoužívanejšie funkcie (textové, matematické, logické, dátumové a 

cyklické) 

Excel VBA obsahuje množstvo funkcií, my si vypíšeme niektoré z nich. 

Zdroj: http://www.excelfunctions.net/VBA-Operators-And-Functions.html 
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Funkcia Akcia 
Kategória 

funkcií 

Abs Vráti absolútnu hodnotu z čísla. Príklad: 

Abs(-10) vráti 10 

Abs (10) vráti 10 

Matemati

cké 

Case Nahrádza použitie funkcie IF (viď If). 

Funkciu zapisujeme cez: Select Case (podmienka) 

Jednotlivé podmienky vypisujeme cez Case Is (ekvivalent Else If). Ak 

neplatí žiadna z nich, tak platí podmienka uvedená v Case Else 

Príklad: 

 

Logické 

Chr Vráti príslušný znak podľa hodnoty v ASCII tabuľke. Vhodné pre 

zobrazenie špeciálnych znakov (€, ö, © a podobne). 

Príklad  

Char(10) vráti nový riadok 

Char(97) vráti znak „a“ 

Zdroj znakov ASCII http://www.asciitable.com/ 

Textové 

Date Vráti aktuálny dátum Dátumové 

DateAd

d 

Pripočíta špecifický čas k dátumu. Formát funkcie je: 

DateAdd(Interval, Number, Date), 

interval – typ argumentu 

number – počet (hodín, dní, rokov, ...) o koľko pripočíta k dátumu 

date – dátum, ku ktorému sa pripočítava 

 

 

 

Dátumové 

http://www.asciitable.com/
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Legenda ku interval 

Interval Reprezentuje 

yyyy Year (rok) 

q Quarter (štvrťrok) 

m Month (mesiac) 

y day of the year (deň roku) 

d Day (deň) 

w Weekday (pracovný deň) 

ww Week (týždeň) 

h Hour (hodina) 

n Minute (minúta) 

s Second (sekunda) 

Príklad: 

DateAdd("d", 1, "1.6.2015")  - pridá 1 deň k dátumu 1.6.2015 

DateAdd("ww", 2, "1.6.2015")  - pridá 2 týždne k dátumu 1.6.2015 

DateDif

f 

Vypočíta počet (interval) medzi dátumami. Formát funkcie je: 

DateDiff(Interval, Date, Date), 

interval – typ argumentu (viď tabuľku vyššie pri DateAdd) 

date1 – dátum 

date2 – dátum 

Príklad: 

DateDiff("d", "1.6.2015", "1.7.2015")  - zistí počet dní medzi 1.6.2015 

a 1.7.2015 

DateDiff("w", "1.6.2015", "1.7.2015")  - zistí počet víkendov medzi 

1.6.2015 a 1.7.2015 

Dátumové 

Day Vráti deň z dátumu. 

Príklad: 

Day ("28.7.2015")  - vráti 28  

Dátumové 

http://www.excelfunctions.net/VBA-Day-Function.html
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For Vhodne pri tvorbe opakujúceho sa príkazu/príkazov 

Príklad: 

  
Výsledok: Vyplní prvých šesť riadkov v prvom stĺpci (teda od A1 do A6) 

 
Výsledok: Vyplní šesť riadkov vzhľadom na aktuálnu pozíciu označenej 

bunky 

Cyklické 

Foreach Prechádza kolekciu údajov bez toho, aby vedela koľko ich je (narozdiel 

od For, kde zadávame konečný počet) 

Príklad: 

 

Výsledok: Sčíta označené bunky (ekvivalent SUM) 

Cyklické 

Hour Vráti hodinu z času. 

Príklad: 

Hour("22:45:00") - vráti 22 

Dátumové 

If Ekvivalent k funkcii IF prakticky s ľubovoľným počtom.  Argumentom je 

podmienka. Ak je podmienka splnená, vráti TRUE, v opačnom prípade 

FALSE. 

Poznámka: Príkaz If  sa používa v spojení  s príkazom: 

Then  - ak je podmienka splnená, tak sa vykoná ... 

Else – v opačnom prípade sa vykoná ... 

ElseIf – je vlastne vnorené If. Ak neplatí hlavné podmienka, tak ... 

Logické 
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End If – koniec používania If 

  

Príklad: 

 

Vypíše odpoveď podľa toho, či je hodnota kladná, záporná alebo 

nezáporná 

Poznámka: Môžeme kombinovať spolu s AND, OR a ďalšími logickými 

funkciami, napr.: 

 

 

InStr Vracia pozíciu hľadaného reťazca v reťazci. Hľadanie začína na zadanej 

pozícií. 

 

Príklad: 

InStr(1, "Here is the searchword", "searchword")  – slovo searchword 

našiel, preto vráti hodnotu 13 

InStr(14, "Here is the searchword but here is another searchword", 

"searchword")  - slovo searchword našiel, hľadá však od pozície 14, 

preto 44 

InStr(1, "www.google.com", ".sk")  - slovo .sk nenašiel, výsledok je 0 

Textové 

Int Vráti celé číslo (nie zaokrúhlené) z desatinného čísla 

Príklad: 

Int(5.79) – vráti hodnotu 5 

 

Matemati

cké 

IsDate Skontroluje, či sa jedná o dátum. Vracia TRUE ak hodnota je dátum, 

v opačnom prípade FALSE 

IsDate("01/01/2015") – hodnota JE dátum, preto vráti True 

IsDate(100) – hodnota NIE JE dátum, preto vráti False 

Dátumové 
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IsError Skontroluje, či bunka obsahuje chybu. Ak áno, vráti TRUE, v opačnom 

príprade FALSE. 

Príklad: 

 

Logické 

IsNume

ric 

Skontroluje či hodnota je číselná alebo nie. Ak áno, vráti TRUE, 

v opačnom prípade FALSE. 

Príklad: 

 

Logické 

Left Vráti v hľadanom reťazci špecifický počet znakov a to zľava (od 

začiatku). Formát funkcie je nasledovný: 

Left(String, Length)  

String – reťazec, v ktorom hľadáme 

Length – počet znakov, ktoré vráti 

 

Príklad: 

Left("abcdefghijklm", 4)  - vráti reťazec "abcd" 

Left("abcdefghijklm", 1) - vráti reťazec "a" 

Textové 

Len Vráti počet znakov reťazca. 

Príklad: 

Len("abcdefg")  - vráti 7, pretože je to 7 znakov 

Textové 

Month Vráti mesiac z dátumu. 

Príklad: 

Month ("28.7.2015")  - vráti 7  

Dátumové 
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Mid Vráti časť textu z textového reťazca na základe pozície odkiaľ a počtu 

znakov. Formát je nasledovný: 

Mid(String, Start, Length) 

String – textový reťazec, z ktorého vyberieme časť textu 

Start – štartovacia pozícia, z ktorej vyberieme text 

Length – počet znakov, ktoré chceme vybrať 

Príklad: 

Mid("abcdefghijklm", 4, 5) – vráti reťazec "defgh" 

Mid("abcdefghijklm", 10, 2) – vráti reťazec "jk" 

Textové 

Minute Vráti minúty z času. 

Príklad: 

Minute ("22:45:15")  - vráti 45  

Dátumové 

Now Vráti aktuálny systémový dátum a čas Dátumové 

Right Vráti v hľadanom reťazci špecifický počet znakov a to zprava (od 

konca). Formát funkcie je nasledovný: 

Right(String, Length)  

String – reťazec, v ktorom hľadáme 

Length – počet znakov, ktoré vráti 

 

Príklad: 

Right("abcdefghijklm", 4) – vráti reťazec "jklm" 

Right("abcdefghijklm", 1) – vráti reťazec "m" 

Textové 

Round Zaokrúhli číslo na konkrétny počet desatinných miest 

Príklad: 

Round(5.79, 1) – zaokrúhli číslo na 1 desatinné miesto, výsledok je 5,8 

Matemati

cké 

Second Vráti sekundy z času. 

Príklad: 

Second ("22:45:15")  - vráti 15 

Dátumové 

Sqr Vráti druhú odmocninu z čísla 

Príklad: 

Sqr(4) – vráti číslo 2 

Matemati

cké 
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Sqr(16) – vráti číslo 4 

Time Vráti aktuálny systémový čas Dátumové 

Year Vráti rok z dátumu. 

Príklad: 

Month ("28.7.2015")  - vráti 2015  

Dátumové 

Matematické operácie s číslami  
 

Operátor Poznámka Príklad Výsledok 

+ Sčítanie = 7 + 2 =9 

- Odčítanie = 7 – 2 =5 

* Násobenie = 7 * 2 =14 

/ Delenie = 7 / 2 =3,5 

\ Celočíselné delenie 
(vracia celú časť) 

= 7 \ 2 =3 

Mod Podiel (vracia zvyšok po 
delení) 

= 7 mod 2 =1 

^ Umocňovanie =2 ^ 3 =8 

Spájanie reťazcov 
V Excel VBA nenájdeme funkciu CONCATENATE tak ako to poznáme v Exceli. Na spájanie reťazcov 

použijeme znak: 

& 

Príklad: 

 

Vypíše: Aktuálna DPH je 20% 

With...End With 
Zefektívňuje zápis zdrojového kódu.  

Zvážme nasledovný kód: 
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Rýchlejšie ho môžeme zapísať nasledovný spôsobom: 

 

Komentáre 
Použijeme v prípade vkladania poznámky do zdrojového kódu. Slúži na popis funkcionality. Na 

poznámky použijeme znak: 

‘ – apostrof 

 

Môžeme použiť  panel Edit (menu View > Toolbar > Edit), kde nájdeme Comment Block (pridanie 

komentára) alebo Uncomment Block (zrušenie poznámok)  

 

Objekty 
Vo Visual Basicu for Application existuje niekoľko typov objektov: 

Application Aplikácia 

Workbook Zošit 

Worksheet Hárok (List) 
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Range Bunka v hárku alebo oblasť buniek 

Cells Bunka v hárku alebo oblasť buniek -  iný formát zápisu 

UserForm Formulár  

Module Modul vo VBA 

Class Module Modul triedy vo VBA 

 

Ukážka kódov – príkladov na objekty 
Názov objektu všeobecne Praktické použitie Výstup 

Funkce MsgBox - Okno so 

správou v kóde 

MsgBox "Microsoft Excel" Vypíše okno: "Microsoft Excel" 

Workbook – Zošit xlsx Workbooks("cogs.xls").Open     Otvorí zošit s názvom "cogs.xls" 

Sheets - Hárok xlsx Sheets("Hárok1").Select Označí hárok s názvom Hárok1 

Range - Bunka Range("B3") = "Pondelok"   Do bunky "B3" bude priradená 

hodnota "Pondelok" 

   Range("B3:B10").Select         Vyberie bunky B3 až B10 

Vybraté akcie s bunkou 
Sú priradené k objektom alebo prvkom 

Akcia Popis Prvok Syntax 

AddComment vlož komentár bunka Range("B20").AddComment 

Clear vymaže obsah i 

formát 

bunka Range("B20").Clear 

ClearComments vymaž komentár bunka Range("B20").ClearComments 

ClearContents vymaž obsah bunka Range("B20").ClearContents 

ClearFormats vymaž formát bunka Range("B20").ClearFormats 

Copy kopíruj bunka Range("B20").Copy 

Cut vyjmi bunka Range("B20").Cut 

Delete odstráň bunku bunka Range("B20").Delete 
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Find nájdi bunka Range("B20").Find 

Formula vlož vzorec bunka Range("B20").Formula 

Paste vlož obsah schránky bunka Range("B20").Paste 

Select vyber bunka Range("B20").Select 

Sort zoraď bunka Range("B20:B25").Sort 

SetFocus prejdi na tento 

prvok 

ComboBox ComboBox1.SetFocus 

Formátovanie buniek 
Ak chceme zafarbiť bunku, tak môžeme použiť: 

ActiveCell.Interior.Color = 36 ' Zafarbi aktualnu bunku bledo 

oranžovou farbou (viď tabuľka farieb nižšie) 

alebo 

Range("A1:A6").Interior.Color = RGB(200, 160, 35) ‘ Zafarbí bunky v 

rozsahu A1 až A6 

 

 

Poznámka: Formátovanie buniek neexistuje vo funkcii, iba v makre! 
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Práca s formulárom 
Menu Insert > UserForm 

Použijeme na tvorbu používateľských formulárov 

 

Základom je prázdny formulár, do ktorého postupne pridávame (napr. ťahaním) formulárové prvky 

(Controls) 

 

1 
2 

3 

4 
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1. Prázdny formulár – vkladáme formulárové polia 

2. Formulárové polia – Label, Textbox, Combobox, ListBox, CheckBox, ... 

3. Vlastnosti – zobrazujú atribúty a vlastnosti jednotlivých častí formulára (napr. Name, 

Caption, Font, Color a podobne ) 

4. Vľavo vidíme názov vytvoreného formulára 

Aby sme formulár z prostredia Excelu mohli otvoriť , vložíme formulárové tlačidlo typu Command 

Button v skupine ActiveX Controls. 

 

 

Na vložené tlačidlo klikneme 2x, čím sa dostaneme do prostredia Microsoft Visual Basic for 

Applications. Dvojklikom sme vlastne vytvorili udalosť (Click), do ktorého zapíšeme nasledovný kód: 

 

Zatvoríme okno Excel VBA a priamo v Exceli deaktivujeme úpravu tlačidlom Design Mode. 

 

Výsledok: 
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Dodatočné informácie 
Dôveryhodné umiestnenia pre makrá: 

jednotka\Program Files\Microsoft Office\Templates 

jednotka\Program Files\Microsoft Office\OfficeXY\Startup 

Zabezpečenie makra pred jeho úpravou heslom 
V Microsoft Visual Basic IDE je potrebné  prejsť do menu: 

Tools -> VBAProject properties -> Protection a tam: 

Lock project for viewing (po potvrdení kódu je vhodné zavrieť a znovu otvoriť zošit) 
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Export makra 
V Microsoft Visual Basic IDE je potrebné prejsť do menu: 

File -> Export file (uloží súbor s príponou .bas). Jedná sa o textový súbor 

Import makra 
V Microsoft Visual Basic IDE je potrebné prejsť do menu: 

File -> Import file (nájsť súbor s príponou .bas) . Jedná sa o textový súbor 

Poznámky 

Ako označiť celú tabuľku 
Range("A1").CurrentRegion.Select 

Ako vložiť vzorec do aktuálnej a definovanej bunky 

 

Relatívne adresovanie 
Zvážme nasledovný príklad 

 

Príklad vlastne spočíta obsah bunky o dva riadky hore a jeden stĺpec vľavo + bunku o riadok hore a 

jeden stĺpec vľavo 

Syntax: RC – row, column (riadok, stĺpec) 

Absolútne adresovanie  Vysvetlenie 

R1C1 A1 

R3C3 C3 

Relatívne adresovanie  

R1C Prvý riadok, v tom istom stĺpci 

RC1 Ten istý riadok, prvý stĺpec 

RC[-2] Pozícia dve bunky vľavo od aktuálneho riadka  a stĺpca 

RC[+3] Pozícia tri bunky vpravo od aktuálneho riadka  a stĺpca 

R[-2]C[-1] Pozícia dva riadky hore a jeden stĺpec vľavo od aktuálne označenej 
bunky  
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Ako premenovať graf 
Sub vytvorGraf() 

' 

' vytvorGraf Macro 

' 

 

' 

    ActiveSheet.Shapes.AddChart.Select 

    ActiveChart.ChartType = xlColumnClustered 

    ActiveChart.SetSourceData Source:=Range("'stĺpcový graf'!$B$4:$E$11") 

    ActiveChart.Parent.Name = "graf" 

 

End Sub 

 

Praktické odkazy 
www.stackoverflow.com – výborné fórum 

www.mrexcel.com – fórum zamerané na Microsoft Excel 

http://www.excel-easy.com/ - postupy ako pracovať s MS Excel vysvetlené jednoduchým postupom 

http://www.techflutter.com/functions.php - praktické ukážky použitia jednotlivých funkcií v MS Excel 

VBA aj na stiahnutie 

https://msdn.microsoft.com/en-us/library/office/ee861528.aspx - referencia na oficiálny web 

spoločnosti Microsoft ohľadom príkazov v Excel VBA 

Úlohy 
Zadania: 

 Spravte makro na priemer napr. troch hodnôt  

 Výpočet obsahu obdĺžnika 

 Vypočítajte obvod obdĺžnika 

 Vytvorte výpočet DPH nad nejakou číselnou hodnotou. 

http://www.stackoverflow.com/
http://www.mrexcel.com/
http://www.excel-easy.com/
http://www.techflutter.com/functions.php
https://msdn.microsoft.com/en-us/library/office/ee861528.aspx

